Dougal Campbell's geek ramblings

WordPress, web development, and world domination.

WordPress 2.2.1 Released

WordPress 2.2.1 is now available. Most of the changes are minor bug fixes, however there are some security fixes as well. We can’t stress enough how important it is to upgrade your sites and keep them current so that you aren’t open to attacks. Many people see these “minor” version updates and assume that they don’t need to install them. Mainly it seems to be folks who worry about an upgrade breaking their theme or their plugins. But if the themes and plugins are written properly, this won’t normally be a problem. So, if you are running any version of WordPress older than 2.2.1, go download the new version now.

If you’re curious about what’s changed since 2.2.0, read the list of changes on Trac. Or, you can view the source code changes for all the changed files.

About Dougal Campbell

Dougal is a web developer, and a "Developer Emeritus" for the WordPress platform. When he's not coding PHP, Perl, CSS, JavaScript, or whatnot, he spends time with his wife, three children, a dog, and a cat in their Atlanta area home.
This entry was posted in Security, Software, WordPress and tagged , , , , . Bookmark the permalink.

19 Responses to WordPress 2.2.1 Released

  1. adam says:

    i think the thing that this announcement got right, that the 2.2 announcement (and so many previous) got wrong is something this post gets wrong too.

    “minor bugfixes” is an addendum to “Patched Security Flaws”. never lead with “minor” if it’s important for people to upgrade. bugfixes are nice. patched flaws are important.

    linking to the vulnerability announcement is important, it gives people an idea of what’s been going on.

  2. Pingback: GaMerZ.WordPress

  3. If I could go back in time and NOT start down the WordPress road, I certainly would! I’m starting to feel like the main purpose of each new release is to create yet another set of security holes, which will require yet another “fix” which will include a whole new set of security holes.

    I’m sick of it. :(

  4. Jesse Harris says:

    Most of us still have some battle scars from the big jumps from 1.5 to 2.0 and again from 2.0 to 2.1. Each of those jumps incurred a large number of broken themes and plugins. I think that it’s entirely appropriate for users to be skittish about upgrading because of those poorly planned migrations and the resultant problems with forward and backward compatibility.

    Most of the plugins and themes for 1.5 were “written properly” for that build. Same deal with a lot of 2.0 plugins and themes. The “written properly” argument places too much of the blame on the theme/plugin authors rather than placing it on developers who didn’t consider compatibility issues thoroughly enough.

    Given the history of breakage, I don’t think we’re unjustified in being terrified of “minor” upgrades. Just look at how many widgets got hosed by the “minor” upgrade from 2.1 to 2.2. Sorry for being so angry, but I think devs need to take a bit more responsibility for these breakage issues than they have in the past.

  5. James says:

    I concur with upgrading fears as there is always something which breaks.

    The latest problem since upgrading to 2.2.1 is that my blog keeps reverting back to the original default Kubrick theme regardless whatever other theme I may had been using.

  6. Julia says:

    Just saying thank you. My great grandmother was a Campbell who moved to Arkansas from Mississippi, and I have a brother who lives in Reno. I wonder if he knows about the meeting.

  7. Thanks for the good advice… I’m taking it…

    Also, 2.2 to 2.2.1 shouldn’t be that big of a deal. I’ve had success so far.

    And praise on The Total Money Makeover! I’m on baby step 2.

  8. adam says:

    @jesse-
    on the one hand, you’re right. devs need to spend more time letting plugin authors and theme authors “burn in” new versions before unleashing them on the public. especially in the case of 2.0, where the beta versions didn’t resemble the release versions.

    on the other hand, backwards compatibility isn’t a panacea. plugin/theme authors need to keep on top of development. since 2.0.5 or so, releases have been pretty stable, and there have been lots of warnings for plugin/theme authors to update their projects.

  9. Don says:

    upgraded to 2.2.1, and my feeds aren’t working now.
    now my feedburner feed is saying “not a valid xml file” and getting the error below.
    I checked, and the wp-rss2.php files are in the wp-includes directory.
    appreciate any assistance.
    db

    ******************************
    Warning: require(/srv/www/userweb30561/html/wp-includes/feed-rss2.php) [function.require]: failed to open stream: No such file or directory in /srv/www/userweb30561/html/wp-rss2.php on line 8

    Fatal error: require() [function.require]: Failed opening required ‘/srv/www/userweb30561/html/wp-includes/feed-rss2.php’ (include_path=’.:/usr/share/php5:/usr/share/php5/PEAR’) in /srv/www/userweb30561/html/wp-rss2.php on line 8

  10. Pingback: Ernies Tech Thoughts

  11. Pingback: WordPress 2.2.1 » Solo Technology

  12. Funky Dung says:

    It’s not just a matter of being skittish about plugins or themes breaking. It’s also just an annoying pain the ass to be constantly upgrading. There ought to be a better system for applying security patches and the like. I love WP and I’m glad the devs stay on top of security threats, but the constant trickle of minor releases gets tiresome. Granted, that happens all the time with operating systems, particularly open source ones, but at least they have relatively painless ways to upgrade with a few mouse clicks.

  13. Pingback: Codebox.dk

  14. Libri says:

    I agree with you: if you have just one site to update, it doesn’t matter, otherwise if you need to upgrade tons of website…. it’s a nightmare.

  15. Pingback: La domo de karotoj » WordPress 2.2.1

  16. Rainer says:

    WordPress is great – but I still use 2.1.2 because it is pretty stable and I want to avoid “upgrade problems”. The only thing that could currently change my mind would be a decrease in CPU load on the server.
    So is there a significant decrease? – I don’t think so – and anyway maybe the plugins are responsible for the (sometimes) heavy load.

    best regards, rainer

  17. Jenny says:

    I must admit I am one of those people who don’t think minor upgrades are critically important, not anymore. I do have a few blogs to upgrade. Maybe there could be an automated upgrade feature that WordPress could release?

  18. word press 2.2.1 has been released and this is required upgrade due to a few security fixes. If you’re running an older version of 2.1.x or 2.2.0 you should upgrade ASAP.

    anyway thanks for the advice.

  19. Gta says:

    Its cool, I use WP for 1 year and i like it very much. It’s good to hear that they make a new version and that it will be better :)

Leave a Reply

%d bloggers like this: